文章目录
  1. 1. 局域网搭建
    1. 1.1. 配置以太网交换机的主机名、Console口令、远程登录口令、超级密码
    2. 1.2. vlan划分
      1. 1.2.1. 用特权模式打开vlan表
      2. 1.2.2. 上面的命令就可以将端口放到指定vlan下面,广播信号只能在同一个vlan下发送,能有效缩小广播范围
      3. 1.2.3. 跨交换机vlan划分
    3. 1.3. 访问控制列表(1~99)
    4. 1.4. 扩展访问控制列表(100~199)
    5. 1.5. DNS域名解析
    6. 1.6. NAT网络地址转换

局域网搭建

配置以太网交换机的主机名、Console口令、远程登录口令、超级密码

  • 准备的内容:

    1. 我们得知道交换机所在的位置?—-为交换机准备一个IP地址。

      1.1 交换机IP地址的配置在哪里?—-配置在虚拟端口VLAN1上
      需要访问交换机的端口:

      switch>enable  --->  switch#  (config terminal--->)
      switch(config)# (interface ID--->) switch(config-if)#
      switch(config-if)#ip address 10.0.0.1 255.0.0.0
      
    2. 配置本地主机,让其与交换机在同一个网段上。

    3. 继续回到交换机做准备工作

      3.1 开放远程telnet访问:–>配置虚拟终端访问协议,
      虚拟终端访问在交换机上通过虚拟终端线路设置来完成的
      要在line模式下完成
 switch(config)#line vty 0 5
switch(config-line)#password xxx
switch(config-line)#login

3.2 继续设置我们的交换机

3.2.1开放交换机的特权命令

要求为enable命令设置一个密码
       switch(config)enable password yyyy

vlan划分

  • 观察当前交换机的划分形式,特权模式用show命令观察。
    Switch>enable
    Switch#show vlan
    
 VLAN Name                             >      Status    Ports
 ---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                            Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                            Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                            Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                            Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                            Fa0/22, Fa0/23, Fa0/24, Gig1/1
                                            Gig1/2
100  VLAN0100                         active    Fa0/1
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 

用特权模式打开vlan表

Switch#vlan database
#创建新的vlan端口
Switch(vlan)#vlan 100、
#为vlan添加成员端口
Switch(vlan)#exit
#进入全局模式
Switch#configure terminal
#设置端口
Switch(config)#interface Fa0/1
Switch(config-if)#
#也可以批量设置端口
Switch(config)#interface range fa0/1 - 4
Switch(config-if-range)#
#下面以单个端口演示,批量端口是一样的,将端口放在vlan 100下面
Switch(config-if)#switchport access vlan 100

上面的命令就可以将端口放到指定vlan下面,广播信号只能在同一个vlan下发送,能有效缩小广播范围

  • 删除vlan:先归还成员,在删除vlan
    Switch#vlan database
    no vlan 100
    

    跨交换机vlan划分

  • 必须保证相同vlan ID的端口间才可以通信
  • 公共端口必须工作在中继模式下
    Switch(config-if)#switchport mode trunk
    #公共的两个端口都要这样设置

访问控制列表(1~99)

  • 全局模式建立如下规则列表
    Router(config)#access-list 1 deny 192.168.1.0 0.0.0.255
    Router(config)#access-list 1 permit any
    

    该规则含义为:拒绝IP地址前缀为192.168.1.的访问,然后允许除此之外的所有IP地址访问。
    接下来将此规则应用到某个接口上。

    Router(config)#int fa1/0
    Router(config-if)#ip access-group 1 out
    注:进入路由器是 in    出路由器是  out
    

扩展访问控制列表(100~199)

  • 全局模式建立如下规则列表

    Router(config)#access-list 100 deny tcp host 192.168.1.2 host 200.11.180.2 eq 80
    Router(config)#access-list 100 permit tcp host 192.168.1.2 host 200.11.180.2 eq 21
    Router(config)#access-list 100 permit any any
    

    该规则含义为:不允许IP地址为192.168.1.2的主机通过http协议访问IP地址为200.11.180.2的主机,但是可以通过ftp的协议方式访问。

  • 将该规则应用到某端口的方法同上。

    DNS域名解析

  1. 想要通过域名访问外网某个web页面,得先在本网段建一个域名解析服务器。
  • 在域名服务器中->config->DNS中添加域名对应的IP地址。
  • 在发送请求的电脑的DNS Server 中填上域名服务器的IP地址。注:请求电脑和域名解析服务器得在同一个Vlan下。

NAT网络地址转换


更多精彩内容,请关注公众号:轮子工厂,公众号内回复:我要造轮子,可免费获得100本计算机经典电子图书; 回复:福利,获取大学生礼包; 回复:加群,邀请您进高手如云技术交流群。

文章目录
  1. 1. 局域网搭建
    1. 1.1. 配置以太网交换机的主机名、Console口令、远程登录口令、超级密码
    2. 1.2. vlan划分
      1. 1.2.1. 用特权模式打开vlan表
      2. 1.2.2. 上面的命令就可以将端口放到指定vlan下面,广播信号只能在同一个vlan下发送,能有效缩小广播范围
      3. 1.2.3. 跨交换机vlan划分
    3. 1.3. 访问控制列表(1~99)
    4. 1.4. 扩展访问控制列表(100~199)
    5. 1.5. DNS域名解析
    6. 1.6. NAT网络地址转换